If you are using the googleSearch (CSE) component , please update this component with the latest version immediately!
This latest version resolves potential Cross Site Scripting as highlighted by joomla.org. Details here.
If you are using this component (any versions, including Joomla 1,0, 1,5, 1.6, 1.7, 2.6 and 3.0 and above), please MAKE SURE you update to the latest version immediately.
Special thanks to Eddie Konczal for highlighting this to me.